X-Plane 11.32+ (X-Plane 10 is NOT supported!)
Windows 7+, Mac OS 10.10+ or Linux 14.04 LTS or compatible, 64 bit mode
8Gb RAM / 2Gb VRAM Minimum, 24Gb+ RAM / 8Gb+ VRAM Recommended
Current Version: 1.2.13 Free auto-updates for the entire XP11 life-cycle